Rockbox.org home
release
dev builds
extras
themes manual
wiki
device status forums
mailing lists
IRC bugs
patches
dev guide



Rockbox mail archive

Subject: RE: AW: Delay between tracks (was: Just a short question)
From: Nielsen Linus (ext) (Linus.Nielsen_at_elema.siemens.se)
Date: 2002-09-16


> I _think_ it isn't a winamp specific problem, but to be honest, I
> haven't done any tests so far. I know several MP3 tag editing programs
> that use this way of writing id3v2 tags, because they don't have to
> write the whole file again when changing some of the tags.

I realized that too after using my head for a few minutes. :-)

> I use Exact Audio Copy V0.9beta4 to rip and encode my music (via LAME)
> and it has this option "Additionally write ID3V2 tags, using a padding
> of xx kb". You can find a similar option in MP3-Tag-Editor and many
> other programs and they all (as far as I remember) recommend
> having this "padding".
> If it is a common problem, I think we should handle it.

I have fixed it, and I am about to commit the changes. We now skip Xing VBR
headers and LAME Info headers as well. The playback should be totally
glitch-free now, except for a special case with the ID3V1 tags that should
be very rare...

What I don't like about the padding is that it adds garbage to the stream
instead of padding the ID3V2 tag. The tag length should have been set to the
total tag size including the padding, IMHO...

/Linus



Page was last modified "Jan 10 2012" The Rockbox Crew
aaa