Rockbox.org home
release
dev builds
extras
themes manual
wiki
device status forums
mailing lists
IRC bugs
patches
dev guide



Rockbox mail archive

Subject: Re: cvs: apps wps-display.c,1.35,1.36 playlist.c,1.55,1.56 playlist.h,1.19,1.20
From: Magnus Holmgren (lear_at_algonet.se)
Date: 2002-10-15


Robert E. Hak wrote:

> Log Message:
> added %pn (playlist name) to wps

<...>

> + case 'n': /* Playlist Name (without path) */
> + playlist_name(buf, buf_size);
> + return buf;

Why not handle it like the file name (%fn)? I.e., use get_dir - and move the extension chopping there to a separate function (or maybe even let get_dir do that if -1 is passed as level)? >:)

  Magnus



Page was last modified "Jan 10 2012" The Rockbox Crew
aaa