Rockbox.org home
release
dev builds
extras
themes manual
wiki
device status forums
mailing lists
IRC bugs
patches
dev guide



Rockbox mail archive

Subject: Re: Rockbox Recording
From: Linus Nielsen Feltzing (linus_at_haxx.se)
Date: 2002-11-11


ijed wrote:
> Just tried out recording on my 1.17i and it seems to be coming along
> very nicely.

Great.

> Mic Input Worked fine

The only thing I have tested :-)

> Line Input worked but I had to turn the gain up on the right channel
> before it started working. Then turned it back down to unity and it
> recorded very well (Seemed like less hiss than the archos firmware, I'll
> try and do some tests)

I think I have fixed that bug now.

> I like the idea of a MMDDhhmm.mp3 time stamp and how about a flashing
> RECORDING mm:ss underneath the peak meters? (Although the record/stop on
> the status bar is good enough i guess)

The file naming issue will be dealt with later. This is only a test.

> Have done a short digital test. It seemed to be monitoring the mic
> input, but when i played it back it was the original, although the level
> had dropped in comparison to the original

Yeah, I guess it drops a little when you pay it back, since the audio
monitoring isn't fed through the sound processing stage.

, and it recorded the 0:27 in
> 160 kbits instead of quality 7 (175kBit VBR?)
> which it specified or 112 kBits which the orignal was in.

This is because I don't save any VBR header in this version. When I do
that, the bitrate reporting will be correct.

> I tried recording the whole 2:22 song and it crashed when I stopped it
> before it got saved to the harddrive

Wow! Not good. How did it crash? Describe the symptoms.

> (But from disc activity it sounds
> like you've only programmed it to record to RAM then write out to
> disc so it can only record up to 1.681MB at the moment.

Why do you think that? It only saves to disk when it needs to, that is
when the buffer is getting empty.

> Third Test 1:46 same settings (Q7) but recorded at 96kBits. Same drop
> in signal level in comparison to original.

See above about VBR header.

> I'm just using a standard 3.5mm Stereo jack (not gold) out the back of
> my SBLive and I haven't used the digital out/in before so it could be a
> hardware thing.
> Just tried digital recording with the Archos Firmware and I get the same
> drop in signal level.

As I suspected.

> Hope this helps. I've got a few SP/DIF outputs on things too. Is
> this a different protocol or do I just need an adapter?

The Digital I/O *is* S/PDIF. :-)

/Linus



Page was last modified "Jan 10 2012" The Rockbox Crew
aaa