Rockbox.org home
release
dev builds
extras
themes manual
wiki
device status forums
mailing lists
IRC bugs
patches
dev guide



Rockbox mail archive

Subject: Re: USB driver in NetBSD-current broken for Archos :-(
From: George Michaelson (ggm_at_apnic.net)
Date: 2002-11-18


On Sun, 17 Nov 2002 16:13:03 -0700 Jason Hill <jch_at_xmission.com> wrote:

> What happens when you try to mount it? NetBSD 1.6 worked for me with
> no effort. FreeBSD on the other hand required some hacking. :)
>
> What does disklabel say?
# disklabel sd0
# /dev/rsd0d:
type: SCSI
disk: DK23DA-20
label: fictitious
flags:
bytes/sector: 512
sectors/track: 32
tracks/cylinder: 64
sectors/cylinder: 2048
cylinders: 19077
total sectors: 39070080
rpm: 3600
interleave: 1
trackskew: 0
cylinderskew: 0
headswitch: 0 # microseconds
track-to-track seek: 0 # microseconds
drivedata: 0

8 partitions:
# size offset fstype [fsize bsize cpg/sgs]
 d: 39070080 0 unused 0 0 # (Cyl. 0 - 19077*)
 e: 39070017 63 MSDOS # (Cyl. 0*- 19077*)
disklabel: boot block size 0
disklabel: super block size 0
#

but a mount of sd0e gives:
# mount -t msdos /dev/sd0e /mnt
mount_msdos: /dev/sd0e on /mnt: Input/output error

and my O/S version is:

# uname -a
NetBSD dhcppc1 1.6K NetBSD 1.6K (GGM) #9: Fri Nov 8 11:24:36 EST 2002
root_at_garlic.apnic.net:/usr/src/sys/arch/i386/compile/GGM i386#

Its USB1.0 on a Dell L400 Laptop.

cheers

-George

PS looks like the lower level driver problem was some kind of transient. I
can't re-create it now, I get this i/o error instead.



Page was last modified "Jan 10 2012" The Rockbox Crew
aaa