Rockbox.org home
release
dev builds
extras
themes manual
wiki
device status forums
mailing lists
IRC bugs
patches
dev guide



Rockbox mail archive

Subject: Re: Buffer Underrun
From: gerald clark (gerald_clark_at_mindspring.com)
Date: 2003-01-11


Even Weirder:

Power off
Reboot
Play MP3
WM 60000
stop
play MP3
WM A410
Stop
change anti skip
play MP3
WM = approx A410 + ( antiskip * F80 )

stop
Power off
Reboot
Play MP3
WM 60000
stop
play MP3
WM A410

It does not appear to be calculating the watermark on the first play.
It does not appear to read the Anti skip value unless you change it.

gerald clark wrote:
> This is Really odd.
> Now the water mark is at 60000 on the same MP3.
>
> gerald clark wrote:
>
>> I am running current CVS version.
>>
>> I like to listen to Wales Radio programs.
>> http://wri.cymru.net/celtic/notes/notidx.htm
>>
>> When playing 32Kbps 22KHz MP3 with anti skip set to the
>> max of 7 seconds, the watermark is at 0x11170.
>> In debug, I see that the buffer position display is
>> only updated every 0x10000 bytes. It appears that
>> the watermark is checked at this time.
>> Since with this MP3, this is every 10 seconds or so,
>> the buffer ocassionally underruns.
>> It does not even turn on the drive until after the buffer reaches 0.
>> Can't the buffer be compared to the water mark more often?
>> Perhaps every 0x8000 bytes instead?
>
>
>

-- 
Gerald L. Clark

Aero TerraTrike #1 http://www.wizwheelz.com/images/clarkaerotrike1.jpg

Member: Sky Soaring

Illinois, U.S.A.

Archos Recorder JBR20101 1.28 0x302 positive 0x200 positive 11.0592



Page was last modified "Jan 10 2012" The Rockbox Crew
aaa