Rockbox.org home
release
dev builds
extras
themes manual
wiki
device status forums
mailing lists
IRC bugs
patches
dev guide



Rockbox mail archive

Subject: Bug: Resumes when it shouldn't.
From: Michael O'Quinn (michael_at_oquinn.info)
Date: 2003-04-08


On Mon, 7 Apr 2003, Brian Wolven wrote:

> Alexandre FLAMENT wrote:
> > When
> > - I stop playback in a middle of a song
> > - Switch off rockbox
> > - Switch on again
> > the rockbox continues to play song even if rockbox wasn't playing before
> > switch off.
> > Is it normal ?
>
> I think that depends on your RESUME settings (F1->General
> Settings->Playback->Resume).

But even with Resume set to Yes (aka Always, and don't ask first), it
should NOT resume when there is nothing TO resume.

There must be some synchronicity here, because I was actually in the
middle of composing the following when this thread started up...

This isn't exactly a show stopper for 2.0, but it is a minor annoyance.

Reference bug 622833 "Resume after End of Song List." This is still not
fixed, although it is reported as having been done.

Basically, what happens is that if Resume is set to Yes, then when a
play list is finished playing and the Archos is shut off (or allowed to
turn itself off via Idle Timeout) the next time it's turned on the last
part of the song is replayed.

I suspect that the fact that the song has ended is not being saved to
disk, so the next time the unit is powered up, RockBox thinks it should
resume. Maybe this is a feature -- to save a tiny bit of power (by not
spinning up the disk) -- but if so it's a poor trade off. I'd much rather
take the (very minor) power hit and have resume work correctly.

I'm using a Player, and running CVS-030404.

Michael



Page was last modified "Jan 10 2012" The Rockbox Crew
aaa