Rockbox.org home
release
dev builds
extras
themes manual
wiki
device status forums
mailing lists
IRC bugs
patches
dev guide



Rockbox mail archive

Subject: Resume bug still partially persists
From: c s (rb_dev_at_yahoo.com)
Date: 2003-04-12


The recent fix put into wps-display.c v1.69 (for
original bug report 622833) still does not completely
fix the problem. At least on the Archos Player, if
resume is turned on and a you start playing a file
from the browser, when the last song in the directory
is finished and the player is shut off, upon the next
power-up the player starts playing the last portion of
the last song that had finished playing when the end
of the playlist was reached.

Strangely this only happens if playback is started by
browsing to an mp3 file and playing it. If playback
is started by browsing to an m3u playlist and playing
it or playback is started via the power on resume, the
erroneous resume of the last portion of the last song
does not occur after shutdown and the next power-up.

If I put a save_settings() followed by an ata_flush()
in wps-display.c right after the recently added
setting of the resume_index to –1, the problem seems
to be completely fixed, but that still doesn’t explain
why the global settings aren’t flushed to the disk in
the one case but they are in the two other cases.

=====
Craig

rb_dev_at_yahoo.com

__________________________________________________
Do you Yahoo!?
Yahoo! Platinum - Watch CBS' NCAA March Madness, live on your desktop!
http://platinum.yahoo.com



Page was last modified "Jan 10 2012" The Rockbox Crew
aaa