Rockbox.org home
release
dev builds
extras
themes manual
wiki
device status forums
mailing lists
IRC bugs
patches
dev guide



Rockbox mail archive

Subject: Re: Can't get WPS to work right. -- further info.
From: Brent Geery (fasttimes_at_mochamail.com)
Date: 2003-04-16


I wrote:

> Björn Stenberg <bjorn_at_haxx.se> wrote:
>
> > Brent Geery wrote:
> > > The second line is totally blank on the Player!
> >
> > Strange, it works in the simulator. Unfortunately, I don't have
> > a real player here to test with right now.
>
> My Player is the 5000, v5.02.
>
> > > There seems to be some limit to the length of the WPS file!
> > > Can we get this increased a bit?
> >
> > The only limit is that the whole file cannot be longer than 300
> > bytes (a bit on the small side for recorder users, but should be
> > plenty for players).
>
> I also tried in the latest v2.0, with the same results. Can some
> other Player/Studio owners try the following WPS, and see if it works
> for you?
>
> First line: %s[%pn %pp/%pe] %fskb %pt %fbkbs/%ffhz:
> %?it<%it - |%fn - >%?ia<%ia - |%d2 - >%?id<%id |%d1 >%?iy<(%iy)>
> Second line: %pr%pb%bt

OK, things are even stranger. I swapped the order of the lines, and
now it functions! This is very odd, and must be a bug of some type.
Again, the following WPS works:

First line: %pr%pb%bt
Second line: %s[%pn %pp/%pe] %fskb %pt %fbkbs/%ffhz: %?it<%it - |%fn -
>%?ia<%ia - |%d2 - >%?id<%id |%d1 >%?iy<(%iy)>

But, the following does not, with the second line being totally blank:

First line: %s[%pn %pp/%pe] %fskb %pt %fbkbs/%ffhz: %?it<%it - |%fn -
>%?ia<%ia - |%d2 - >%?id<%id |%d1 >%?iy<(%iy)>
Second line: %pr%pb%bt

Both are exactly the same, only swapping the order of the lines.

-- 
BRENT - The Usenet typo king. :)

Fast Times At Ridgemont High Info http://www.FastTimesAtRidgemontHigh.org Voted #87 - American Film Institute's Top 100 Funniest American Films



Page was last modified "Jan 10 2012" The Rockbox Crew
aaa