Rockbox.org home
release
dev builds
extras
themes manual
wiki
device status forums
mailing lists
IRC bugs
patches
dev guide



Rockbox mail archive

Subject: Battery information while charging
From: Jean Boullier (jean.boullier_at_wanadoo.fr)
Date: 2003-07-17


I have kept an eye (or two) on battery information in my WPS during a
full charge from low (about 20%) to full and I have got confirmation of
something I had already noticed without being too sure: during this
charging cycle the estimated time went down as if it was in fact showing
how long it would take to reach full charge...

When I started the time was something between 2h30mn and 3h. Then as the
percentage was raising normally (with the small variations inherent to
the way one can measure this level) the estimated time went on
decreasing. At 80 % it was 53 mn, and at 91 % it was 30 mn. At this
point just while I was watching the screen the percentage jumped to 100
% and the estimated time become what it should be, i.e. 10h20mn (I have
the standard 1500 mA batteries in my JBR6).

Is this an undocumented feature of Rockbox or is it only a confirmation
that some things are not going as they should in the charging routine?
During this time I have had a look at Debug information one or two times
and the figures were consistent with the WPS display.

I am running CVS.030711, my box is not (caanot be) flashed, and actually
I do not think that this behaviour is proper to this version of Rockbox.

-- 
Jean Boullier - Rouen - Normandie - France



Page was last modified "Jan 10 2012" The Rockbox Crew
aaa