dev builds
themes manual
device status forums
mailing lists
IRC bugs
dev guide

Rockbox mail archive

Subject: I dont think the flashing tool should be a plugin..
From: George Styles (
Date: 2003-07-25

    .. i think it should be built into the main firmware. The reason being
that its a PITA when you get incompatable version error.

When I re-build the daily release, I like to put the .ucl find on the JB and
update all the .rocks.

At the moment, I need to keep the old rockboxflash.rock somewhere else, for
the job of flashing.

It would be much nicer if I could just flash from the firmware, with having
to worry about the version of the flasher I have

This would reduce the 'upgrade procedure' from about 4 steps to 2 or so

what do people think? i love the plugin system, but I think this should be a


Page was last modified "Jan 10 2012" The Rockbox Crew