Rockbox.org home
release
dev builds
extras
themes manual
wiki
device status forums
mailing lists
IRC bugs
patches
dev guide



Rockbox mail archive

Subject: results of first player flashing
From: idc-dragon_at_gmx.de
Date: 2003-08-26


Gizz volunteered and last evening we went ahead, see IRC log.
The flashing business itself worked very well, we started carefully with 2
different Archos software versions in the dual boot. After the bootloader was
verified, with the safety of a working "permanent" image, we used the normal
update procedure (UCL "playing") to try Rockbox in the second image.

This is not working yet, I suspect again missing inits, Rockbox does not run
cold-started on Players yet. The symptoms are:

- no harddisk spinup
- display backlight goes on
- nothing displayed
- red LED flashing with maybe 1 Hz

A bit similar to what I had with my recorder on first attempt, it's display
was blind, too.

I think we're lacking LCD init, plus the unpowered HD or so sends it into a
panic, hence the LED flashing. Does this ring any bells? Afaik, players have
no HD power control, so why doesn't it spin up?

I'd have a hard time finding this, because a) no gdb capability on this unit
and b) it's "remote debugging", I don't have it.

Jörg

PS: Gizz made some video clips of the flashing (first I thought he's
joking), they're here:
http://coolrabbitz.online.fr/rockbox/
The clips are very large files because of MJPEG compression, show the flash
procedure and startups of the Archos images, but not the bad one with
Rockbox.

-- 
COMPUTERBILD 15/03: Premium-e-mail-Dienste im Test
--------------------------------------------------
1. GMX TopMail - Platz 1 und Testsieger!
2. GMX ProMail - Platz 2 und Preis-Qualitätssieger!
3. Arcor - 4. web.de - 5. T-Online - 6. freenet.de - 7. daybyday - 8. e-Post



Page was last modified "Jan 10 2012" The Rockbox Crew
aaa