Rockbox.org home
release
dev builds
extras
themes manual
wiki
device status forums
mailing lists
IRC bugs
patches
dev guide



Rockbox mail archive

Subject: Flashed recorder & charging
From: David S. Geirsson (david_at_loesje.nl)
Date: 2003-10-04


Hi. I just got my Recorder 20 recently, and of course the first thing I
did was install rockbox on it. :)

I was annoyed by the load time of the Archos, but I knew that you could
flash rockbox into the flash ROM, so I tried that. It then booted in
just over two seconds. :)

However, there is one problem: When I have the rockbox loader flashed,
charging stops working properly. It seems that it can't detect the
battery status properly while charging. Yesterday I drained my batteries
almost dry (I think they were at about 9%, not surprising as I'd been
using the player all day). Then I started the charging (note: I was not
using the charging screen that pops up when you plug in the charger with
the recorder off -- I booted rockbox first, as I knew some people had
had problems with the charge screen. Now, it started charging, and I
went out. When I came back, around an hour later, it had stopped
charging, and seemed to think the battery was at 100% (which of course
it wasn't, as it had been near-empty just an hour ago). I checked in the
debug screen, under battery info, and sure enough, it was not charging
the battery. I then turned off the box, and back on. Rockbox booted, and
promptly greeted me with ~16-20% battery status (I don't remember
exactly what it was.)

I wanted to know if there is a known solution (besides using the archos
charging...) to this, and if anyone was having this problem? I think I
saw messages on this list about people having such problems with FM
recorders, but this is a non-FM model.

By the way, charging works fine in rockbox with the original archos
firmware flashed.

Thanks,

-- 
David S. Geirsson
david_at_loesje.nl
+31 642561928 (0642561928)



Page was last modified "Jan 10 2012" The Rockbox Crew
aaa