Rockbox.org home
release
dev builds
extras
themes manual
wiki
device status forums
mailing lists
IRC bugs
patches
dev guide



Rockbox mail archive

Subject: Re: Windoze 98se & Slow USB 2.0
From: BlueChip (cs_bluechip_at_webtribe.net)
Date: 2004-02-19


>>>I have noticed lately that my JBR20 seems to be a little slow.
>>>
>>>Given the recent article on SlashDot, I donwloaded Sandra to sniff the
>>>USB port once the drive was connected.
>>>
>>>Sandra reports:
>>>
>>>Root Hub: USB Port 1
>>>Status : Device Connected
>>>Device Connected to Port : USB Storage Adapter V3 (TPP)
>>>OEM Device Name : In-System Design USB 2.0 ATA Bridge
>>>Device Version : 11.01
>>>Device ID : VEN_05AB, DEV_0060, PRT_00
>>>USB Version : 2.00
>>>Speed : Full (12Mbps)
>>>Configuration Settings : 1
>>>Open Pipes : 2
>>>Transfer Type : Bulk
>>>Data Packet Size : 64 bytes
>>>
>>>What concerns me is that 12Mbps is the "Full" speed of USB 1.1 ...USB
>>>2.0 should be running at 480Mbps afaict
>>>
>>>I have tried both of the drivers on the Archos site, and both give the
>>>same results.
>>>
>>>Does anybody have any idea what I am doing wrong or maybe where I can
>>>find more generic drivers?
>>
>>
>>maybe try this one? http://downloads-zdnet.com.com/3000-2098-10163320.html
>>
>>i am running windows XP and i checked out sandra's report. it looks the
>>same as yours except mine says:
>>
>>Speed: High (480Mbps)
>>
>>from quick googling it looks like usb2.0 support in 98 is not widespread
>>and might be dependent on the device manufacturer supplying a specific driver.
>>
>>-jsd-
>
>I'm awaiting a long (and very slow) transfer right now (hence checking my
>email), I will try the suggested driver, probably tomorrow now, and get
>back to you/the group.
>
>You have clearly put in a fair chunk of effort to bring me that
>information - web browsing and probably installing Sandra - I'm not sure
>how I can return the favour, but in the mean time, I hope "Thank You" will
>suffice :)
>
>BC

Follow up:

...I just checked the readme file and those drivers are not for my specific
card :(

I have tried USB-card drivers recommended by Linus also, but have yet to
work out how to uninstall the old Archos drivers so that I can try the new
Cypress ones (safe mode->remove device is not sufficient!)

...I wonder how many other poeple are running slow and maybe are not even
aware of it?

Well, that's enough of replying to myself :)

BC

_______________________________________________
http://cool.haxx.se/mailman/listinfo/rockbox



Page was last modified "Jan 10 2012" The Rockbox Crew
aaa