Rockbox.org home
release
dev builds
extras
themes manual
wiki
device status forums
mailing lists
IRC bugs
patches
dev guide



Rockbox mail archive

Subject: Re: Video plugin and tools problems/limitations
From: Jens Arnold (arnold-j_at_t-online.de)
Date: 2004-02-20


Hello [IDC]Dragon

On 19.02.2004, you wrote:

>>> May be a bug. I have meanwhile implemented 2.5, without
>>> testing it, I send it to you in a separate email. Maybe it
>>> changes the 2 behaviour as well, but I don't think so.

>> It doesn't change the MPEG2 behaviour at all. Here are the
>> new results for MPEG2.5:

> I have to test for myself to see what's going on. What tool
> did you use to generate your test streams?

As stated in my post of Feb 17, all my test files were prepared
with LAME 3.95.1 on windows. VBR files were created with
--preset medium, CBR files with --preset CBR <bitrate>, where
bitrate was 96 kBit/s for 24000/22050 Hz, 64 kBit/s for 16000 Hz
and 48 kBit/s for 12000/11025 Hz. No ID3v1 or ID3v2 tags or
other esoteric stuff was added.

>> > I have also speeded up halftone.exe by a factor of 3. In
>> > there some really suboptimal code from my first tries was
>> > never reworked. Feel free to redistribute, I can't update
>> > my webspace right now.

>> Couldn't test this one since it is apparently compiled with
>> #define PROFILING and I have no Windows C compiler at hand :(

> Sorry, yes I noticed later on. Will email you a new one...

I have temporarily uploaded them to my webspace (also happens to
be at T-Online). I hope this is ok for you.

>>>>> Strange, I only set the volume, because it can be muted
>>>>> when the plugin starts. The others I don't touch. ...

>>>> But it definitely does reset these. I tested ...

>> Other people have reported that as well. I set the volume
>> and init the playback. Maybe there are some side effects. I
>> currently can't compile Rockbox, while being in Taiwan.

>> I guess this has to wait until you are back in good old
>> europe then...

> I think I found it. I should not do the mp3_play_init(). The
> box is normally initialized for playback already, only after
> recording we have to do this call. It resets the MAS. If you
> can compile rockbox, can you remove this one and test it?

Unfortunately I did not yet set up a development environment for
Rockbox. I guess this will need some time, since I've already
installed some cygwin components and have to check what to keep
and what to overwrite. Perhaps I will do this at the weekend.

Regards, Jens

_______________________________________________
http://cool.haxx.se/mailman/listinfo/rockbox



Page was last modified "Jan 10 2012" The Rockbox Crew
aaa