Rockbox.org home
release
dev builds
extras
themes manual
wiki
device status forums
mailing lists
IRC bugs
patches
dev guide



Rockbox mail archive

Subject: Re: Charging w/USB "Feature" found and bug?
From: Linus Nielsen Feltzing (linus_at_haxx.se)
Date: 2004-03-18


vze2dr3m_at_verizon.net wrote:
> Anyway, I have been having a major-league problem getting my system
> flashed. I keep getting the file not found when I run the
> rockbox_flash.rock file. Anyway, I'll try to redo everything from
> scratch.

> However, it pointed me to 2 strange things:
>
> 1) When in debug and looking at the battery information, I plugged in
> the USB cable. It didn't connect to the USB, but started charging. I
> backed out to the main display and it continued charging.

This is one of the reasons why it says "keep out". Don't expect anything
to work normally when you're in there.

> 2) Since, I was connecting and disconnecting the USB after putting
> more flash files on the drive, I ran into a problem where I got a
> "ata error -71" with the latest release for the v2 downloaded today.
> I couldn't connect again for the life of me. I rolo'd (I think that's
> what it's called) back to the version from the flash package and I
> could connect again without problem.

¤nteresting. Was that when you extracted the USB plug?

> Is it bad to charge via USB this way? It would enable me to listen to
> rockbox while charging at work. If this is okay, would it be possible
> to setup a charging connector mode so people wouldn't have to go into
> debug.

No it's not bad to charge that way. You are of course confusing the USB
driver, but it should recover when you extract the plug again.

I just might add that feature one day.

Linus
_______________________________________________
http://cool.haxx.se/mailman/listinfo/rockbox



Page was last modified "Jan 10 2012" The Rockbox Crew
aaa