Rockbox.org home
release
dev builds
extras
themes manual
wiki
device status forums
mailing lists
IRC bugs
patches
dev guide



Rockbox mail archive

Subject: Speech/talk problem
From: BlueChip (cs_bluechip_at_webtribe.net)
Date: 2004-06-06


It's my night for spotting weird stuff...

Probably mostly directed at Jo"rg this one...

By example: If I enable menu speech, go to the main menu and hold my finger
on down for a few of seconds the voice jumps and jitters from one option to
the next

BUT, and here's the thing that's got me puzzled... the last option is not
spoken in full, normally just the last little bit of the word ...exmple, if
I end on "recording" the speech will say "<skip><jump><skip><jump>ING" and
NOT "<skip><jump><skip><jump>RECORDING"

It seems that the queue is filling, although in the new Audio controls I
issue a talk_spell("",false) to force a shutup() before I start each word;
still the start of words are often missing.

This is also the same with queued stuff. Eg. "minus" "0" "d" "b" ....I
might hear "<skip><jump>db"

The final thing is that I can get "<skip><jump>recording" if I don't hold
the button for too long, maybe 1.5s is okay but 3s causes a trailing word
fragment (times are estimates.)

I think there is a problem with shutup(), but there may be some weird
buffer thing that you already know about, so I thought I'd ask before I
went hunting.

Cheers

BLueCHiP

_______________________________________________
http://cool.haxx.se/mailman/listinfo/rockbox



Page was last modified "Jan 10 2012" The Rockbox Crew
aaa