Rockbox.org home
release
dev builds
extras
themes manual
wiki
device status forums
mailing lists
IRC bugs
patches
dev guide



Rockbox mail archive

Subject: Re: serial line interference problems
From: BlueChip (cs_bluechip_at_webtribe.net)
Date: 2004-06-16


Just a couple of wild guesses...

1. Have you checked that the line-in is disabled on the MAS?

2. Have you tried the anti-skip buffer to resolve the skipping issue?

Maybe I guess lucky today?

BC

At 09:45 16/06/04, you wrote:
>Hi all
>
>I did finish the development of my cd changer emulation. But there was one
>thing I never did during the development: listen to the music.
>Yesterday, I installed my sony head unit and my archos in my car, then I
>discovered 2 problems:
>First there is a very audible noise due to serial communications. I have
>choosed to use the line-in connector, instead of the ear because of the
>auto power on mod, to connect the serial line. Does anyone knows if the
>noise is due to the line-in connection or directly because of the serial
>line? have people who made the serial mod noticed noise interference
>during communications?
>
>My second problem is partialy resolved: The software tx path that I used
>was blocking interrupts inside the interrupt handler, causing pops in the
>sound because of mp3 buffer underruns I think. What I did is lower the
>serial interrupt level to 4 and allow interrupts during software tx. Now
>there are no more pops but I have lots of transmission error.
>Does anyone have a suggestion?
>
>I think I will have to connect the serial tx to the rx line so there will
>be no more interrupt masking.
>
>Regards
>Sophana
>_______________________________________________
>http://cool.haxx.se/mailman/listinfo/rockbox

_______________________________________________
http://cool.haxx.se/mailman/listinfo/rockbox



Page was last modified "Jan 10 2012" The Rockbox Crew
aaa