dev builds
themes manual
device status forums
mailing lists
IRC bugs
dev guide

Rockbox mail archive

Subject: Re: Driver in XP, no long file names
From: Fabian Cenedese (
Date: 2004-06-25

>>that`s a weirdness (bug?) i experience from time to time, too.
>>(after plugging/unplugging several times, or after suspend/resume of my notebook)
>>maybe this is a explorer-bug - but it`s not related to archos/rockbox, because i saw it on my other portable hdd, too.
>Same here. It always happens if I don't select "open explorer" in the popup
>after connecting the unit.
>>open taskmanager, kill all explorer.exe and start explorer.exe again.
>>works for me.
>How do you restart explorer, since killing the last instance of it kills the
>My workarounds:
>Most of the time, selecting "my computer" from the desktop, right clicking in
>the window and selecting "refresh" will do the trick.
>Almost always, control panel->system->hardware->device manager, clicking on
>any device, right clicking and selecting "scan for hardware changes" will do
>the trick. This forces winders to do a plug'n'pray scan just like when the
>hardware is plugged in. sometimes the above steps are also necessary.
>If that fails, open the USB device tree and remove (click and hit DEL) the USB
>driver for the Archos. Usually identified by the internal drive name such as
>"Hitachixxxxx". Then right click and "scan for hardware changes". This makes
>plug'n'pray find the "new hardware" and install the driver again. This brings
>the drive back about 99.999% of the time.
>When it doesn't, reboot.
>If it's so fouled up that rebooting doesn't help, go back to device manager
>and nuke the entire USB tree, then do a "scan for hardware changes". It'll
>take some time for plug'n'pray to run through all the "new hardware" and
>install the drivers. I've only had to do this a few times but it has always

Thanks for the good hints, I will try next time I have it.

bye Fabi


Page was last modified "Jan 10 2012" The Rockbox Crew