Rockbox.org home
release
dev builds
extras
themes manual
wiki
device status forums
mailing lists
IRC bugs
patches
dev guide



Rockbox mail archive

Subject: Re: Unrecognizable filenames after upgrade to Fedora Core 2
From: sophana (jobarjo78_at_yahoo.fr)
Date: 2004-08-27


Johan Vromans wrote:

>Andreas Stemmer <groovingandi_at_gmx.de> writes:
>
>
>
>>My line for the jukebox looks like the following:
>>
>>/dev/sda1 /mnt/jukebox vfat
>>rw,users,quiet,umask=002,iocharset=iso8859-1,codepage=850,noauto,uid=1000,gid=1001 0 0
>>
>>
>
> % mount | grep archos
> /dev/sdd1 on /mnt/archos type vfat (rw,iocharset=iso8859-1,codepage=850)
>
>but I still get ? instead of real ISO-8859-1 characters.
>
>Any more suggestions?
>
>-- Johan
>_______________________________________________
>http://cool.haxx.se/mailman/listinfo/rockbox
>
>
>
I don't think it is filesystem related.
I have the same problems in my ext3 FS.
But when exported through samba, the chars are ok.

Even under windows with cygwin under ntfs with xterm (and even with the
windows command prompt with bash!), I have these '?' chars.
I have no problem with the native windows command prompt (msdos shell)

Finally I think it is bash or whatever your shell that filters these
characters.

I haven't found why yet, but it should be related to some
internationalization packages to be installed and with some environment
variable to be set.

_______________________________________________
http://cool.haxx.se/mailman/listinfo/rockbox



Page was last modified "Jan 10 2012" The Rockbox Crew
aaa