Rockbox.org home
release
dev builds
extras
themes manual
wiki
device status forums
mailing lists
IRC bugs
patches
dev guide



Rockbox mail archive

Subject: iRiver On button Problem

iRiver On button Problem

From: Mat Holton <mathew.holton_at_surface-inspection.com>
Date: 2005-07-26

Hi there,

Can anyone help me?

I recently recieved a 'broken' iRiver H120 from my brother. He had been charging it with a Nokia charger.
I've looked into the spec of the Nokia charger and the polarity is the same as iRiver charger (center positive).
The difference is the voltage and current, both less than the proper charger.

It's now charged fully using the proper charger.

The problem is that it doesn't come on! Well, it does by only by pressing the reset button.

My brother also mentioned that he tried to re-flash the firmware but it froze half(?) way, i.e. it didn'y gracefully exit in the correct way.
This sounds like it may have caused the problem (I neglected to ask if the problem was there beforehand).
And the same thing happens if I try and re-flash now. But it still boots up with reset.

Does anybody have any clue as to how to solve the problem or does it sound like it's a hardware fault, perhaps causes by a faulty firmware upgrade
procedure?

Perhaps if it was low on current, the firware didn't flash completely? Or would it just not work at all?

any help would be great,

thanks,

mat
_______________________________________________
http://cool.haxx.se/mailman/listinfo/rockbox
Received on Tue Jul 26 10:30:27 2005


Page was last modified "Jan 10 2012" The Rockbox Crew
aaa