dev builds
themes manual
device status forums
mailing lists
IRC bugs
dev guide

Rockbox mail archive

Subject: Re: rockboxx becoming non-responsive + loud POP noise when shutting down (iriver)

Re: rockboxx becoming non-responsive + loud POP noise when shutting down (iriver)

From: Frederic Devernay <>
Date: 2005-07-28

In fact I just noticed I get that (very) loud POP only if I triggered the bug
described in my other message (rockboxx becoming non-responsive..., cited below)
in the same session.
Probably the DSP in in a bad state when this happens...


BlueChip wrote:
> We had this problem with the Archos units a long time ago. iirc it was
> the last patch I submitted to the patch tracker. It _should_ be quite a
> trivial fix. It is caused by the speaker moving to a rest position when
> the signal is removed. The most probable fix is to turn the volume down
> very quickly (I use ~5mS when doing production work) before removing the
> power.
> Hope that helps,
> BC
>> When rockboxx is shut down, I get a very loud POP sound which kills my
>> ears (I use in-ear earphones). If someone knows where to look for that
>> bug, I didn't get it in the 20050716 CVS version, so this must be a
>> recent bug. Any ideas?
>> Rockboxx version used: CVS, no patches
>> Fred

Frederic Devernay wrote:
> I noticed that a few days ago:
> Play a song, and keep adjusting the volume, from 0 to 100 to 0
> back-and-forth.
> After a few seconds, you'll see the volume setting adjusts more slowly,
> and rockboxx becomes very slow to respond to keypresses. Actually, at
> that point, the volume doesn't get adjusted anymore. STOP+PLAY doesn't
> cure this, now you have to shutdown.
> This doesn't happen on the simulator or in builds before July 16th
> (which had many other problems anyway).
> Rockboxx version: CVS, no patches, iriver H120.
> Fred
> _______________________________________________
Received on Thu Jul 28 17:52:46 2005

Page was last modified "Jan 10 2012" The Rockbox Crew