Rockbox.org home
release
dev builds
extras
themes manual
wiki
device status forums
mailing lists
IRC bugs
patches
dev guide



Rockbox mail archive

Subject: Re: *PANIC* recfile: -4 and lose everything

Re: *PANIC* recfile: -4 and lose everything

From: espammy <espammy_at_gmail.com>
Date: 2005-10-10

Tom,
 Thanks for your response. I will go back and find an earlier version of
Rockbox to try, although I would expect the same, or similar error. I'll
also F1 boot into the Archos firmware and see if that helps.
 I created and formatted the partition via XP's Logical Disk Management
console.
 I don't know, it just seems that the Archos is a POS. This is my second one
and they've both had issues.

 On 10/6/05, Tom Cole <tcole@xtra.co.nz> wrote:
>
> Wow, this looks like a show-stopper for Rockbox 2.5!
>
> Do previous versions of Rockbox record ok?
>
> How did you create the partition on your recorder?
>
>
>
> On Wed, 5 Oct 2005 12:52:55 -0700, you wrote:
>
> >I have a Archos JBR V2 (P/N 4000028) with a strange problem. I am
> >running the Rockbox 2.5 firmware and have also successfully flashed
> >the unit. I have reformatted and re-unzipped the 2.5 firmware, so
> >starting out clean.
> >
> >Here's the issue: whenever I try to record, everything appears to be
> >going fine (Time and Size increments, levels move, etc) until I end
> >the recording. As soon as I stop the recording I get the following
> >display:
> >
> >*PANIC*
> >recfile: -4
> >
> >The green light is on and the red light is flashing.
> >
> >At that point I hold the OFF button for 10 seconds or so to turn off
> >the unit. When I turn it back on I get the messages "No rockbox
> >directory" and "Installation incomplete."
> >
> >If I hook the unit up to my laptop at this point, here's what the
> >directory listing looks like"
> >
> > Directory of F:\
> >
> >02/04/1980 12:03 AM 0 A
> >07/31/1980 12:07 AM 16,711,935 A
> >02/04/1980 12:02 AM 0 R
> >03/15/1980 12:03 AM 110 B
> >03/21/1980 12:03 AM 6,619,245 ?
> >02/04/1980 12:04 AM 0 S
> >02/04/1980 12:01 AM 196,680 a
> >02/04/1980 12:04 AM 0 m
> >02/04/1980 12:03 AM 65,742 1
> >The parameter is incorrect.
> >02/04/1980 12:03 AM 16,711,935 A
> >02/04/1980 12:06 AM 0 R
> >03/16/1980 12:03 AM 51 A
> >02/04/1980 12:00 AM 65,727 N
> > 14 File(s) 40,706,858 bytes
> > 0 Dir(s) 17,302,339,584 bytes free
> >
> >Any idea what is happening here? Bad disk? I've reformatted several
> >times now, ran chkdsk, etc all to no avail. Seems to work fine until
> >I try to record.
> >
> >Don't know if this helps any:
> >
> >[Hardware Info]
> >ROM: 1.23
> >Mask: 0x0104
> >USB: positive
> >PR: positive
> >Flash: M=BF D=D6
> >ROM CRC: 0x222F V1
> >ATA: 0x200,master
> >
> >[Partitions]
> >P0: S:3F
> >T:C 19069 MB
> >
> >Disk info:
> >HITCHI_DK23DA-20
> >
> >Thanks!
> >
> >___________________________________________________________
> >Sent by ePrompter, the premier email notification software.
> >Free download at http://www.ePrompter.com.
>
>
Received on Mon Oct 10 17:16:44 2005


Page was last modified "Jan 10 2012" The Rockbox Crew
aaa