Rockbox.org home
release
dev builds
extras
themes manual
wiki
device status forums
mailing lists
IRC bugs
patches
dev guide



Rockbox mail archive

Subject: Re: Small bug in wps

Re: Small bug in wps

From: Dave Wiard <lists_at_wiard.net>
Date: 2006-02-12

Nisse wrote:
> I first want to thank you all for making rockbox. Thanks!
> Second I found a small bug in the wps:
> when using the conditional volume tag to display images
> the previous displayed volume image is not cleared when you lower the
> volume.
> For example you make a slider like:
>
> %xl|g|vol1.bmp|118|169|
> %xl|h|vol2.bmp|118|169|
> %xl|i|vol3.bmp|118|169|
> %xl|j|vol4.bmp|118|169|
> %xl|k|vol5.bmp|118|169|
> %xl|l|vol6.bmp|118|169
> %xl|m|vol7.bmp|118|169|
> %xl|n|vol8.bmp|118|169|
> %xl|o|vol9.bmp|118|169|
> %xl|p|vol10.bmp|118|169|
> %?pv<|%xdg|%xdh|%xdi|%xdj|%xdk|%xdl|%xdm|%xdn|%xdo|%xdp>
>
> and when you turn the volume up all the way the slider is full but when you
> turn it down again the slider stays full. If you stop playback and then
> go back to wps
> it displays correctly again.

I've noticed a similar problem with the battery images. They all display
fine when the battery is at all levels except one. This is the same WPS
and same image files I've been using for many months and I don't update
all that frequently so it could have been introduced anytime since late
October. And it just hasn't bothered me enough to fix it, yet.

Dave
kenshin/kawika/sithia
Received on Sun Feb 12 15:53:11 2006


Page was last modified "Jan 10 2012" The Rockbox Crew
aaa