Rockbox.org home
release
dev builds
extras
themes manual
wiki
device status forums
mailing lists
IRC bugs
patches
dev guide



Rockbox mail archive

Subject: Re: My iRiver doesn't work anymore

Re: My iRiver doesn't work anymore

From: James Teh <jamie_at_jantrid.net>
Date: 2006-02-23

There seems to be a bug with the voice UI. If it is enabled and you go
into record mode without actually recording to disk (i.e. you just go
into the recording screen), lots of things break when you hit stop to
exit the recording screen. If you hit record while in the recording
screen to actually record audio to disk, it will work just fine when you
exit the recording screen.

Devs: Would a temporary work around be to call audio_buffer_steal()
always, even if not recording to disk? It seems that this is called when
recording to disk, but not otherwise, which might explain why recording
to disk causes no problems?
I don't really understand the code well enough yet to be sure of that,
but it's just something I spotted in my investigation ...
As we don't get any speech in the recording screen anyway, I can't see
the harm. Or is this itself a bug?

Jamie

Rainer Jost wrote:
> Hi all,
> I told You, that my iRiver H340 works well. Now it doesn't. I wanted to
> test the recordfunktion and it worked well. When I stopped the record,
> no mor sound comes from the player. Have someone else that problem?
> Or is that a problem, that nobody knows?
> Rainer

-- 
James Teh
Email: jamie@jantrid.net
WWW: http://www.jantrid.net/jamie/
MSN Messenger: jamie@jantrid.net
Jabber: jteh@jabber.org
Yahoo: jcs_teh
Received on Thu Feb 23 15:10:40 2006

Page was last modified "Jan 10 2012" The Rockbox Crew
aaa