dev builds
themes manual
device status forums
mailing lists
IRC bugs
dev guide

Rockbox mail archive

Subject: Re: OS X Compilation errors for iPod

Re: OS X Compilation errors for iPod

From: Sean Clark <>
Date: 2006-03-02

The arm-elf-gcc version I have is: gcc version 2.95.3 20010315

I used gcc version 4 to compile arm-elf-gcc.

I will try compiling arm-elf-gcc from source without using darwin ports.

Thanks for the quick reply.

On 3/2/06, Daniel Stenberg <> wrote:
> On Thu, 2 Mar 2006, Sean Clark wrote:
> I think you should consider the rockbox-dev mailing list for this kind of dev
> stuff in the future.
> > I tried compiling it on OS X 10.4, and I get this error:
> >
> > cc1: Invalid option `long-calls'
> What gcc version are you using when you get this? We do recommend using gcc 4
> for ARM builds.
> > I tried a few versions of arm-elf-gcc, one I compiled myself throug darwin
> > ports, and another package I found on the internet. Both don't have the
> > -mlong-call option.
> We recommend you build your own from source, as described in the Rockbox wiki.
> --
> Daniel Stenberg -- --
Received on Thu Mar 2 09:39:12 2006

Page was last modified "Jan 10 2012" The Rockbox Crew