dev builds
themes manual
device status forums
mailing lists
IRC bugs
dev guide

Rockbox mail archive

Subject: Re: OS X Compilation errors for iPod

Re: OS X Compilation errors for iPod

From: Dave Chapman <>
Date: 2006-03-02

Sean Clark wrote:
> The arm-elf-gcc version I have is: gcc version 2.95.3 20010315
> I used gcc version 4 to compile arm-elf-gcc.
> I will try compiling arm-elf-gcc from source without using darwin ports.

I've had no trouble building Rockbox under Mac OS X - it works fine.

2.95.3 is far too old for arm-elf-gcc - as you've found, it doesn't work
at all. arm-elf-gcc 4.0.2 (and binutils 2.16) is currently the version
used by the Rockbox iPod developers (and the version used to produce the
official downloads on

I would definitely recommend compiling your own arm-elf-gcc from source
- it works smoothly on Mac OS X, and the only people that seem to have
problems setting up a cross-compiler seem to be the people using
pre-compiled packages. There are instructions for this on the Rockbox wiki.

Received on Thu Mar 2 10:06:16 2006

Page was last modified "Jan 10 2012" The Rockbox Crew