dev builds
themes manual
device status forums
mailing lists
IRC bugs
dev guide

Rockbox mail archive

Subject: Re: ian and his v1.04US h300

Re: ian and his v1.04US h300

From: ian douglas <>
Date: 2006-04-03

> I downloaded the 1.29k zip file and it has an .exe file inside which I
> obviously can't run in Linux, and my 'wine' setup won't open it either.

So I downloaded the 1.29k firmware directly from iRiver and:
- grabbed the "bleeding edge" tools
- descrambled the firmware
- ran mkboot
- scrambled it back up
- checked that my md5sum matched the site (and it did)
- copied the new .hex file to h300.hex on the root directory of my H320
- unziped the latest daily build for the H300 series
- unplugged the unit
- told the H320 to upgrade the firmware

... and got the same result: the unit doesn't seem to power on.

I held in the Play button for 2 seconds and nothing happened on the
screen. I waited over 60 seconds and nothing.

Since the documentation I've read says that for the H300 series I should
only tap the play button to turn it on, I tried that, and waited about a
minute and still nothing happened.

But as soon as I plug in the power cable, it immediately turns on
without pressing any keys, and the iRiver firmware (not Rockbox). If I
plug in a USB cable instead of the power cable, nothing at all happens.
If I have the USB cable attached and tap the on/play button, nothing
happens after a minute. Still on the USB cable I press the on/play
button for 2 seconds, and still nothing. So the only way into the
original firmware (and being able to use the drive to copy files around,
is with the original power cable.

Any suggestions?

Received on Mon Apr 3 23:45:28 2006

Page was last modified "Jan 10 2012" The Rockbox Crew