Rockbox.org home
release
dev builds
extras
themes manual
wiki
device status forums
mailing lists
IRC bugs
patches
dev guide



Rockbox mail archive

Subject: Re: Playlist problems with Rockbox on Iriver H320

Re: Playlist problems with Rockbox on Iriver H320

From: Brandon Low <lostlogic_at_lostlogicx.com>
Date: 2006-04-11

I've been reworking large bits of the software codec playback engine
lately. The latest build still has some of this trouble, but it works
somewhat well. Give it a few more days and it should be 'normal' again.

For more information on the status, keep an eye on the
SoftwareCodecPlayback wiki page.

Brandon

On Tue, 04/11/06 at 18:26:47 +0200, Andreas Heinz wrote:
> Hi there,
>
> hope somebody can help me out, or can confirm that the following
> behavior of rockbox is a bug:
>
> recently i switch on my iriver and boot up (bootloader v2) into rockbox.
> my iriver resumes playback. since i use shuffle over the complete
> harddisk i often have to skip tracks. yesterday i replaced a cvs version
> of march with the daily build of yesterday.
>
> now i have the problem, that the track rockbox displays isn't the track
> rockbox plays. so e.g. i see song A in display but song B is played.
> i'm quite sure rockbox always plays the song after the song which is
> displayed. so when i would have the following playlist:
>
> A
> B
> C
> D
>
> rockbox would play B C D and so on. can someone confirm this?
> as jens suggested in cvs logs i saved the config and resetted rockbox. i
> took yesterdays daily build since i have these ticking problems with the
> remote and the cvs log showed some changes regarding this problem.
>
> unfortunatly now i'm fighting with these playlist problems.
>
> additionaly when i skip songs, rockbox party begins playing them from
> the middle not the beginning.
>
> hope someone can help me out :)
>
> bye
> Andreas
Received on Tue Apr 11 23:24:04 2006


Page was last modified "Jan 10 2012" The Rockbox Crew
aaa