Rockbox.org home
release
dev builds
extras
themes manual
wiki
device status forums
mailing lists
IRC bugs
patches
dev guide



Rockbox mail archive

Subject: Help! Playlist issues with RockBox on an iRiver H340

Help! Playlist issues with RockBox on an iRiver H340

From: Nick von Korff <nickvk_at_itouch.com.au>
Date: 2006-05-18

Hi all,

I have been having real trouble recently with getting through playlists on
my H340 player, running RockBox. What happens is that the player simply
freezes at seemingly random places through the playlist. It may get 100
songs through, it may get 3 songs through, but with regularity it freezes up
completely, to the point that I have to use a paper-clip to reset it. I have
resorted to carrying one in my wallet for when this happens on a train or
bus.

I have no issues whatsoever if I play individual albums, but as soon as I
put a playlist on, I'm guaranteed a freeze within an hour, sometimes far
less (as in 10 minutes).

I've tried virtually everything I can think of to nail down the cause of the
problem, but I can't find any one thing that does it specifically.

I thought it might be particular tracks that may be encoded oddly causing
issues, but these tracks play through fine outside of a playlist.

I've wiped out Rockbox completely on the player and re-installed with the
latest build, even to the point of downloading a new copy of the iRiver
firmware, patching it and installing the firmware again, just to be sure,
but still have the same problems. It wasn't an upgrade to the firmware, just
overwriting the existing version 1.29 firmware.

I've also tried seeing whether playlists created on the player itself
perform any differently to my normal playlists, which I create through
WinAmp, but exactly the same problem.

I've tried playlists of varying lengths, from 100 songs to 4500 songs, but
guess what? Same problem.

Is there any logging or debugging (that may be useful to the devs) that I
can activate on my player to find out exactly what is going when it freezes?

The symptoms of the freeze is that the player is still on, but not playing
sound and is unresponsive to any button presses. If the screen is off when
it crashes, the player remains on, but with no display. If the screen is on,
the display stays on, unmoving, until you reset the player.

Most of the time, the player picks up where it left off after a reset, but I
have on a few occasions, seen it drop all of it's configuration.

From memory, I didn't have these sorts of issues to start off with.

I'm wondering whether it has anything to do with the introduction of album
art to my collection. That is the only thing I have changed. Album art looks
great on the iRiver H3x0 players, BTW. Love it.

Anyway, if anyone has any suggestions or even similar results, please let me
know, as I am REALLY keen to get to the bottom of this problem.

Thanks and regards,

Nick v K.
Received on Thu May 18 04:16:07 2006


Page was last modified "Jan 10 2012" The Rockbox Crew
aaa