Rockbox.org home
release
dev builds
extras
themes manual
wiki
device status forums
mailing lists
IRC bugs
patches
dev guide



Rockbox mail archive

Subject: Re: charging questions

Re: charging questions

From: Andrew Hart <ahart_at_dim.uchile.cl>
Date: 2006-06-23

Well, cripes. Maybe I've been living on another planet for the last
four months and just imagined that it never did it before. *smile*

But seriously, even now, it doesn't seem to start up every time I
plug in the AC adapter. Maybe it is starting the Iriver firmware,
but doesn't always spin up the disk. *shrug* I can't see the
screen, so probably stuff is showing up there that i'm missing.

So, just to have it straight, when the AC adapter is plugged into an
Iriver H300 hosting Rockbox, Rolo is supposed to start the stock
standard Iriver firmware every time. Is that the intended behaviour
for the time being?

Thanks heaps and cheers,
Andrew.

At 16:16 23-06-2006, you wrote:
>I have always had it the way that pluggin in the charger to the
>switched off device started the device and started the iriver software
>starts up.
>There was a bootloader-version for a few days or week that attempted
>to start rockbox on powerup. But it was bogus, and therefore reverted.
>
>~lImbus
>
>On 6/23/06, Andrew Hart <ahart@dim.uchile.cl> wrote:
>>Interesting. Two days ago, I compiled up a 20060621 cvs update for
>>my Iriver H340. After installing this build, I can no longer turn
>>off Rockbox while the AC adapter is plugged in. Rockbox pauses a
>>moment and simply rereads the currently selected file in the file browser.
>>
>>I am sure I have never had any difficulties with this before now. To
>>turn it off, I have to momentarily unplug it, hold stop, wait to hear
>>the drive spin up and down and the audio switch off so I know it's
>>actually going to shut down properly. then I can plug it back into
>>the power. Though, sometimes after plugging it back into the power,
>>the Iriver firmware boot spontaneously. I'm watching this trying to
>>determine if there's something I'm doing that's causing the original
>>firmware to start, but I didn't notice this happening before
>>INSTALLING THIS BUILD. It seems that if I hold stop, wait for the
>>drive to spin down and plug in the AC adapter, there is a pause for a
>>few seconds and the Iriver firmware starts. I need to do some more
>>concerted testing to see if this happens every time, but it is
>>happening a lot.
>>I'll update cvs and recompile later today or on the week-end when I
>>have time to see if that makes a difference.
>>
>>Anyone else seeing anything like these little probs?
>>
>>Cheers,
>>Andrew.
Received on Fri Jun 23 22:55:33 2006


Page was last modified "Jan 10 2012" The Rockbox Crew
aaa