Rockbox.org home
release
dev builds
extras
themes manual
wiki
device status forums
mailing lists
IRC bugs
patches
dev guide



Rockbox mail archive

Subject: Re: IO device error with ipod

Re: IO device error with ipod

From: Rob Powell <rob_at_rinty.plus.com>
Date: Thu, 27 Jul 2006 09:23:00 +0100

Hi Paul I do. I'll give that a go, except that the music is on an external HD.

Rob At 23:51 26/07/2006, you wrote:
>If you have any other storage devices hooked up via USB, try
>disconnecting them all before plugging in the iPod.
>
>On 7/26/06, Matthew Caron <<mailto:matt_at_mattcaron.net>
>matt_at_mattcaron.net> wrote:
>This is a bit of a circular logic, but it might help you isolate the
>fault. It assumes your XP install is using NTFS
>
>(1) Grab a recent linux LiveCD, preferably one that reads NTFS.
>Something like <http://www.knoppix.org/>http://www.knoppix.org/ might work.
>(2) Boot it
>(3) Try to copy files from your XP partition to the iPod.
>(4) See what happens.
>
>Possible conclusions:
>
>- If it works, then it's Windows.
>- If it doesn't work, then it could be your USB controller or the iPod
>firmware.
>
>You could also try a separate USB controller, if you have one.
>
>Also, is the iPod connected directly or via a hub? Back in my firmware
>days, I found a great deal in variation as to how well hubs worked. Most
>of the chips on motherboards seem to work fine, so plugging it directly
>into the computer usually solved most issues.
>
>Which brings up a question for the rockbox folks: What's the deal with
>USB on iPods? Is all you need is for someone to write a mass storage
>device driver for it? If so, maybe I could help. I'm getting married
>this weekend, but after I come back from my honeymoon, my schedule is
>pretty free.
>
>Rob Powell wrote:
> > Hi all, I really could use some help with this one, as I'm a bit stuck.
> >
> > I'm running XP, and have my Ipod connected to a USB port. I've used the
> > same port for an Archos player and so on before with no problems. I'm
> > copying music to my ipod, and some of the time, I get "unable to perform
> > request because of an IO device error". It's not predictable, in that
> > sometimes it'll copy about 10 albums before it crashes, sometimes 1
> > track. the files that it crashes on can usually be copied individually.
> >
> > I've tried both copy and paste and send to, I use my computer rather
> > than windows explorer (only from habit), I just wondered if anyone had
> > any bright ideas?
> >
> > Thanks for any help,
> >
> > Rob
> >
>
>--
>--------------------------------------------------------------------
>PGP Key:
><http://www.mattcaron.net/pgp_key.txt>http://www.mattcaron.net/pgp_key.txt
>~~ Matt Caron ~~
>
Received on 2006-07-27


Page was last modified "Jan 10 2012" The Rockbox Crew
aaa