Rockbox.org home
release
dev builds
extras
themes manual
wiki
device status forums
mailing lists
IRC bugs
patches
dev guide



Rockbox mail archive

Subject: RE: MakeVoices.vbs

RE: MakeVoices.vbs

From: <steve_at_steve-audio.net>
Date: Thu, 27 Jul 2006 08:53:42 -0400

I'm experiencing the exact same symptoms. Same operating system, same file
structure, and same command to revert the lang file back to the old format.
Some help from one of the scripters would be very welcomed at this point.
All I can think of is that the SAPI stream isn't being created, but without
knowing which error code to look for I can't add any additional trapping to
the script.

Original Message:
-----------------
From: Mitchell Smith mjs_at_fastmail.com.au
Date: Thu, 27 Jul 2006 20:31:05 +1000
To: rockbox_at_cool.haxx.se
Subject: MakeVoices.vbs

Greetings,

I am having some difficulties getting MakeVoices.vbs to function correctly
on my system.

My main objective is to create english.voice files using Neospeech and
Cepstral voices, however I can't even get it working with Microsoft Mary at
this point.

Just to give you some background on my current setup ...

I have downloaded the latest daily build source archive and unpacked it on
a
NetBSD box. I then ran the following command from inside the
rockbox/app/lang directory "../../tools/genlang -o -e=english.lang -t=h300
english.lang > newenglish.lang".

I then copied newenglish.lang to C:\MakeVoices on a Windows XP machine and
renamed it to english.lang. The rest of the files in my C:\MakeVoices
folder are as follows ...

_voice_pause.wav
english.lang
lame.exe
ListVoices.vbs
MakeVoices.vbs
voicefont.exe
wavtrim.exe

I have also installed Microsoft SpeechSDK 5.1 so I have the Microsoft SAPI5
voices.

I tried running MakeVoices.vbs unmodified, which has Microsoft Mary
uncommented, "cscript MakeVoices.vbs".

"Making english voice file with "Microsoft Mary" (SAPI 5)"

and it drops straight back to the prompt.

If I now look in my MakeVoices folder, I see english_Microsoft Mary.voice
with size 4.9 KB.

I have tried running "lame" "wavtrim" and "voicefont" from the MakeVoices
folder, to make sure they can all be executed successfully.

I have tried changing the voice to another installed SAPI 5 voice, with the
same result.

I am not sure what to try next, and with out any error messages from the
MakeVoices.vbs script, I am not sure what is causing it to fail.

Has anyone experienced similar behaviour from this script, and if so, what
did you do to resolve the problem?

Any comments or suggestions would be greatly appreciated.

Thanks,

Mitchell

--------------------------------------------------------------------
mail2web - Check your email from the web at
http://mail2web.com/ .
Received on 2006-07-27


Page was last modified "Jan 10 2012" The Rockbox Crew
aaa