Rockbox.org home
release
dev builds
extras
themes manual
wiki
device status forums
mailing lists
IRC bugs
patches
dev guide



Rockbox mail archive

Subject: Re: IO device error with ipod

Re: IO device error with ipod

From: Matthew Caron <matt_at_mattcaron.net>
Date: Tue, 01 Aug 2006 22:35:10 -0400

>> I'm finding it especially annoying because, on some machines, after
>> disconnecting from USB, the iPod likes to reset the Rockbox
>> configuration.
>
> I've found that it resets too, but thought it was a me thing. Maybe
> that's the cause.

I think I've found out why this happens:

Given:
(A) If you switch on the hold button while the iPod is booting Rockbox,
it clears the settings.
(B) When you disconnect the USB cable, the iPod automatically reboots
into Rockbox.

Then the following sequence of events causes this:
(1) Turn hold switch on.
(2) Plug in to USB.
(3) iPod goes into disk mode
(4) Unmount iPod so it says "okay to disconnect"
(5) Disconnect iPod
(6) Reboots into Rockbox
(7) Hold switch still on, so it clears settings.

Solution:
- Turn hold switch off before plugging in to USB.

It would be nice if it only cleared settings if hold was turned on while
booting (detects off->on transition), but I don't know if Rockbox is
awake enough at that point to do this.

-- 
--------------------------------------------------------------------
PGP Key: http://www.mattcaron.net/pgp_key.txt
 ~~ Matt Caron ~~
Received on 2006-08-02

Page was last modified "Jan 10 2012" The Rockbox Crew
aaa