Rockbox.org home
release
dev builds
extras
themes manual
wiki
device status forums
mailing lists
IRC bugs
patches
dev guide



Rockbox mail archive

Subject: Re: Problems installing Rockbox on iriver h320

Re: Problems installing Rockbox on iriver h320

From: Glenn at home <GlennErvin_at_cableone.net>
Date: Fri, 6 Oct 2006 19:33:40 -0500

A Blind user should be able to do this.
Glenn
----- Original Message -----
From: "Earle" <e.zwicker_at_sympatico.ca>
To: "Rockbox" <rockbox_at_cool.haxx.se>
Sent: Friday, October 06, 2006 8:06 AM
Subject: Re: Problems installing Rockbox on iriver h320

I have a question regarding installing rockbox. You mentioned that your
friend had to redo the firmware
upgrade, how did he do that, without sighted assistance?
----------

Earle, and Peterson, (The Prince)

Msn:
rowdyamerican_at_hotmail.com

Skype: rowdyamerican

Yahoo: rowdyamerican

AIM: rowdyamerican28

ICQ: 155852055
----- Original Message -----
From: "James Teh" <jamie_at_jantrid.net>
To: "Rockbox" <rockbox_at_cool.haxx.se>
Sent: Friday, October 06, 2006 8:37 AM
Subject: Re: Problems installing Rockbox on iriver h320

Hi Paul,
I know this is going to sound stupid and I didn't believe it myself when
I heard about it, but try doing the firmware upgrade again. My friend as
a US Iriver H320 and no matter what he did, Rockbox wouldn't boot, even
after the firmware upgrade. I wonder whether the firmware upgrade
aborted for some reason - he is also blind and didn't have sighted
assistance after the upgrade (a sighted person told him it did seem to
be upgrading though). Anyway, despite my misgivings, he tried the
firmware upgrade again and it came up into Rockbox fine. I still don't
understand why, but there you have it.

Jamie

Paul Hopewell wrote:
>
> Hello,
> I am a new list member. I am visually impaired and am thus excited about
> the speech capabilities of rockbox. I recently purchased a reconditioned
> iriver h320 and am currently unsuccessfully trying to install rockbox on
> it. I would much appreciate any suggestions on why it does not work.
> I have done the following:
>
> 1. Downloaded the latest daily build for the iriver h300 from the
> rockbox WEB site and moved it to the iriver. This gave me a folder
> .rockbox and a file rockbox.iriver of 361 KB.
> 2. Downloaded the fonts package and moved it to the .rockbox folder
> on the iriver. I could only find a single fonts package on the
> rockbox WEB site. Is the font package the same for all platforms?
> 3. Downloaded the MS Mary voice and renamed it to english.voice and
> moved it to the langs folder on the iriver. this voice is 1498 KB.
> I noted that the langs folder contains lng files for nots of
> non-English languages. Should I delete all these?
> 4. Downloaded the iriver firmware 1.28EU from the iriver SWEB site.
> 5. Patched this firmware with fwpatcher.exe which I downloaded from
> the iriver h300 section of the Rockbox WEB site. This claimed to
> be successful and gave
> me a h300.hex file of 4091 KB.
> 6. Transfered the patched firmware to the iriver and did the firmware
> upgrade. This all seemed to work. The firmware upgrade process
> shut down the iriver as expected.
> 7. Restarted the iriver. I expected menus to then start talking.
> However as far as I could tell the iriver seemed to still boot the
> iriver 1.28 firmware. the buttons and menus seemed to be the same
> as those that existed before I started the rockbox install.
>
> I believe my iriver is a USA model as it came with a USA charger.
> However I suspect that this is not relevant.
> Any ideas on what I should do next? Should I have deleted all music
> files from the iriver before starting the rockbox install? Should I have
> upgraded the firmware before moving the Rockbox code onto the iriver?
> Could I have installed the wrong fonts package and if so what would be
> the effect? Does the fonts package live under the .rockbox folder or
> does it live inside some subfolder? Should I delete non-English files
> from the langs folder? Is there some way to tell whether the firmware
> upgrade worked OK? re this point if I start the iriver with the USB
> cable connected to my computer the iriver seems to hang until I unplug
> the USB cable (as expected if the firmware upgrade had worked) but the
> iriver is not visible to my computer.
> Do the file sizes I mention above look OK?
> Many thanks for your help.
>
> Paul Hopewell
> hopewell_at_hopewell.org.uk <mailto:hopewell_at_hopewell.org.uk>
> www.hopewell.org.uk <http://www.hopewell.org.uk>

-- 
James Teh
Email: jamie_at_jantrid.net
WWW: http://www.jantrid.net/
MSN Messenger: jamie_at_jantrid.net
Jabber: jteh_at_jabber.org
Yahoo: jcs_teh
Received on 2006-10-07

Page was last modified "Jan 10 2012" The Rockbox Crew
aaa