Rockbox.org home
release
dev builds
extras
themes manual
wiki
device status forums
mailing lists
IRC bugs
patches
dev guide



Rockbox mail archive

Subject: RE: More on Recording problem

RE: More on Recording problem

From: Stephen Clower <steve_at_steve-audio.net>
Date: Sat, 16 Dec 2006 10:57:22 -0600

Good morning Steve,

I can't speak definitely for other machines, but recording in the default
44.1 kHZ stereo wave format on the H100 line of players results in 0-byte
wave files, and the machine locks up. Plugging the device into USB and
pressing play resets the unit, but the recording doesn't survive. I have
seen similar reports on the list for X5 users as well. The UDMA patch from
November 21 appears to only affect the X5 and H100 series, not the 300 line.
I hope this helps narrow things down somewhat.

As a side note, how do you have your RB development environment configured?
I would really like to get a working copy set up here so I might some day
contribute to the project.

My best,
Steve

-----Original Message-----
From: rockbox-bounces_at_cool.haxx.se [mailto:rockbox-bounces_at_cool.haxx.se] On
Behalf Of Steve B
Sent: Saturday, December 16, 2006 9:53 AM
To: rockbox_at_cool.haxx.se
Subject: Re: More on Recording problem

Hi Stephen,

> Going through the RB changelog, it looks like the ultra DMA alignment
> committed on November 21 is what broke PCM recording support in Rockbox.
> Would one of the devs mind changing this back so we can record once more?

Which recording problem is this? Is it on Flyspray? Which device? I'm not
being cheeky, but recording seems to work on the H340 at the moment.

Yours,

-- 
Steve B
-- 
No virus found in this incoming message.
Checked by AVG Free Edition.
Version: 7.1.409 / Virus Database: 268.15.20/588 - Release Date: 12/15/2006
 
-- 
No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.1.409 / Virus Database: 268.15.20/588 - Release Date: 12/15/2006
 
Received on 2006-12-16

Page was last modified "Jan 10 2012" The Rockbox Crew
aaa