Rockbox.org home
release
dev builds
extras
themes manual
wiki
device status forums
mailing lists
IRC bugs
patches
dev guide



Rockbox mail archive

Subject: RE: more... recording on the iAudio x5

RE: more... recording on the iAudio x5

From: Stephen Clower <steve_at_steve-audio.net>
Date: Sun, 7 Jan 2007 13:35:29 -0600

Erin,

 

This is a known RB issue which presently affects all the coldfire processor
targets including the I-audio X5, Iriver H1xx, and Iriver H3xx devices. From
the research I have done, the problem is tied in with the UDMA additions
made on November 19 and the properties of the voice file you are using. So
far as recording is concerned, I don't know what benefits UDMA adds, though
I'm sure it helps in some way. I have asked for assistance on this list to
help find out what specifically needs to be changed in the voice files to
allow RB to record properly, but so far, I have only been told that certain
people have voice files which don't cause the recorders to hang. What we
need, though, are the specific settings used to generate the voice files in
the first place, not yet another one-stop shop for voices. That has, and
always should be, the voice building wikki at Rockbox.org.

 

Until this issue is truly resolved, I suggest you stick with the November
18, 2006 daily build of Rockbox for your I-Audio. This recommendation holds
true for anybody with a coldfire-based device.

 

All my best,

Steve

 

  _____

From: rockbox-bounces_at_cool.haxx.se [mailto:rockbox-bounces_at_cool.haxx.se] On
Behalf Of Erin Chaves
Sent: Sunday, January 07, 2007 11:51 AM
To: Rockbox
Subject: more... recording on the iAudio x5

 

Hey, all,

 

I know others have reported having recording issues with their X5s, so I
won't go on about this. I just wanted to chime in and say that I'm having
recording issues as well.

My player freezes after I try to record something. I can go in and out of
the recording screen with no problems, but once I press 'play' and/or
'record', the problem appears. I can turn the recording off, and then I'm
stuck in the recording screen, and the only way I can get out of it is to
turn off the player. then the recorded files are always blank.

I wanted to make sure this was a Rockbox issue, because I bought my player
refurbished, and I didn't want to be in possession of a faulty unit. I
reinstalled the iAudio firmware, and with sighted assistance, I discovered
that the recording feature was working.

What's curious to me is that some people are having no problems at all. I
wonder if it depends on the model of the iAudio? I have a 30-G X5L.

 

Erin
Received on 2007-01-07


Page was last modified "Jan 10 2012" The Rockbox Crew
aaa