Rockbox.org home
release
dev builds
extras
themes manual
wiki
device status forums
mailing lists
IRC bugs
patches
dev guide



Rockbox mail archive

Subject: Re: Voice problem bug fixed

Re: Voice problem bug fixed

From: Hamish Mackenzie <hamish_at_mackenzieoz.com>
Date: Sat, 10 Mar 2007 00:36:01 +1100

----- Original Message -----
From: "Linus Nielsen Feltzing" <linus_at_haxx.se>
To: "Rockbox development" <rockbox_at_cool.haxx.se>
Sent: Friday, March 09, 2007 8:41 PM
Subject: Voice problem bug fixed

> Hi all!
>
> I just fixed a nasty issue with the voice file loading. It turns out that
> the new main menu revealed a long-standing bug in the voice file handling.
> On some platforms, under certain conditions, the voice file could be
> loaded before the audio subsystem was initialized, which could lead to
> buffer corruption and the voice was disabled.
>
> This fix should solve the issue where the voice file wasn't loaded even if
> the settings were reset.
>
> Please try the latest SVN build and see if the problem is gone.
>
> Thanks,
>
> Linus

Damn it. I had experianced this for the last couple of days and decided to
format my Nano using the old Ipod firmware updater I had from about a year
ago and whilst I was doing that I checked the mail and saw this lol Well I
guess it needed a freshen up. I noticed the problem yesterday with the
daily build from Mar 08 along with Andres laurance and reed files from the
same date. What would happen was that RB would boot up and start speaking
as normal and then after about 10 seconds or so a data abort error would
come on screen according to my good lady with the good eyes. Ah well I will
go grab the latest bootloader and the latest build and report back.

Cheers

Hamish

>
>
Received on 2007-03-09


Page was last modified "Jan 10 2012" The Rockbox Crew
aaa