Rockbox.org home
release
dev builds
extras
themes manual
wiki
device status forums
mailing lists
IRC bugs
patches
dev guide



Rockbox mail archive

Subject: Re: Updating Rockbox

Re: Updating Rockbox

From: Bradley Alexander <storm_at_tux.org>
Date: Thu, 31 May 2007 11:49:55 -0400 (EDT)

Thanks for that. I installed the new H10.mi4 as well as H10_20GC.mi4 into the System directory, but now rockbox hangs at the ROCKbox splash screen. with "Loading..." but it never completes loading. I believe that I originally had H10_20GC.mi4 in there, but I had the same problem, so I added the H10.mi4. Did I miss a step?

Thanks,
--b

----- Original Message -----
From: "Barry Wardell" <barry.wardell_at_gmail.com>
To: "Rockbox" <rockbox_at_cool.haxx.se>
Sent: Thursday, May 31, 2007 4:26:56 AM (GMT-0500) America/New_York
Subject: Re: Updating Rockbox

On 5/31/07, Daniel Stenberg <daniel_at_rockbox.org> wrote:
> My guess: you have an older bootloader that loads the rockbox image from the
> root directory primarly, while recent Rockbox zip packages have moved that
> image into the .rockbox directory - and that's where recent bootloaders look
> for it first.
I'd guess an old bootloader too. It's probably loading the old style
rockbox.h10 file instead of the newer rockbox.mi4. Delete the
rockbox.h10 file from both the root directory and from inside the
.rockbox directory if it's there too. You should still have a
rockbox.mi4 file inside the rockbox directory. If the bootloader
complains about not being able to find rockbox.h10 the next time you
power on, then you need to download an up-to-date bootloader from
http://download.rockbox.org/bootloaders/iriver/
and put it in your System directory, replacing the old bootloader that's there.
Received on 2007-05-31


Page was last modified "Jan 10 2012" The Rockbox Crew
aaa