Rockbox.org home
release
dev builds
extras
themes manual
wiki
device status forums
mailing lists
IRC bugs
patches
dev guide



Rockbox mail archive

Subject: Re: Updating Rockbox

Re: Updating Rockbox

From: Bradley Alexander <storm_at_tux.org>
Date: Thu, 31 May 2007 19:02:39 -0400 (EDT)

Rockbox boot loader
Version: r12862 12866-070326
iRiver H10 20GB
HTC426020G7CE10
Partition 0: 0x0C 19077MB
Loading Rockbox...
CRC32: 1560CAAC <-- (I think)
model id: h10
binary type: RBOS

The rest is not up long enough to catch (I rebooted it multiple times to try to get the information), but one thing I notice is that the version is still 070326 instead of 070531.

After this page scrolls, it goes to the rockbox splash with Loading... and stops there. The bottom says "Ver. r13529-070531"

Hopefully this will be enough to point to the problem...

Thanks,
--b

----- Original Message -----
From: "Barry Wardell" <barry.wardell_at_gmail.com>
To: "Rockbox" <rockbox_at_cool.haxx.se>
Sent: Thursday, May 31, 2007 5:31:56 PM (GMT-0500) America/New_York
Subject: Re: Updating Rockbox

There are two H10.mi4 files, but they are both for different versions of the 5GB. The H10_20GC.mi4 file is the only one you need.

Can you copy down exactly what it says on your H10 screen when you start it up? You may need to hold down a button (any button) in order for the debug text to appear.

On 5/31/07, Bradley Alexander < storm_at_tux.org > wrote:

I have the 20GB, which is why I originally used the 20GC.mi4. I wasn't sure what the H10.mi4 was for, since there is also a 5GB.mi4 file. I followed the manual as well as the instructions below, and still having problems.

----- Original Message -----
From: "Barry Wardell" < barry.wardell_at_gmail.com >
To: "Rockbox" < rockbox_at_cool.haxx.se >

Sent: Thursday, May 31, 2007 12:08:44 PM (GMT-0500) America/New_York
Subject: Re: Updating Rockbox

Which model of H10 do you have? H10_20GC.mi4 is for 20GB models, and H10.mi4 is for 5/6GB models. I suggest following the installation instructions as given in the manual:

http://www.rockbox.org/manual.shtml

On 5/31/07, Bradley Alexander < storm_at_tux.org > wrote:

Thanks for that. I installed the new H10.mi4 as well as H10_20GC.mi4 into the System directory, but now rockbox hangs at the ROCKbox splash screen. with "Loading..." but it never completes loading. I believe that I originally had H10_20GC.mi4 in there, but I had the same problem, so I added the H10.mi4. Did I miss a step?

Thanks,
--b

----- Original Message -----
From: "Barry Wardell" < barry.wardell_at_gmail.com >
To: "Rockbox" < rockbox_at_cool.haxx.se >
Sent: Thursday, May 31, 2007 4:26:56 AM (GMT-0500) America/New_York
Subject: Re: Updating Rockbox

On 5/31/07, Daniel Stenberg < daniel_at_rockbox.org > wrote:
> My guess: you have an older bootloader that loads the rockbox image from the
> root directory primarly, while recent Rockbox zip packages have moved that
> image into the .rockbox directory - and that's where recent bootloaders look
> for it first.
I'd guess an old bootloader too. It's probably loading the old style
rockbox.h10 file instead of the newer rockbox.mi4. Delete the
rockbox.h10 file from both the root directory and from inside the
.rockbox directory if it's there too. You should still have a
rockbox.mi4 file inside the rockbox directory. If the bootloader
complains about not being able to find rockbox.h10 the next time you
power on, then you need to download an up-to-date bootloader from
http://download.rockbox.org/bootloaders/iriver/
and put it in your System directory, replacing the old bootloader that's there.
Received on 2007-06-01


Page was last modified "Jan 10 2012" The Rockbox Crew
aaa