Rockbox.org home
release
dev builds
extras
themes manual
wiki
device status forums
mailing lists
IRC bugs
patches
dev guide



Rockbox mail archive

Subject: RE: iriver Troubles

RE: iriver Troubles

From: Grant Hardy <grant_hardy_at_telus.net>
Date: Fri, 29 Jun 2007 23:52:13 -0700

Aww man! I had a bad feeling that might've been the cause, but didn't know
if that would be possible. Maybe somehow a chip got bumped and it always
thinks a USB cable is connected now? Maybe someone could tell me if this is
likely and maybe where to look to get that fixed? Thanks all.

Grant

-----Original Message-----
From: rockbox-bounces_at_cool.haxx.se [mailto:rockbox-bounces_at_cool.haxx.se] On
Behalf Of Linus Nielsen Feltzing
Sent: Friday, June 29, 2007 11:36 PM
To: Rockbox
Subject: Re: iriver Troubles

Grant Hardy wrote:
> A technician replaced the hard drive and battery in my iriver H340. The
> hard drive works splendidly in USB mode. I have an older version of the
> RB bootloader and need to update to the latest, but I can't get my
> player to boot up to the iriver firmware. Pressing and holding RECORD
> and PLAY displays a message on screen: "Connected" and shows a picture
> of a USB cable! And just pressing and holding Play causes the Rockbox
> bootloader to come up and go into "USB mode" it says. It's as if the
> USB circuit is frozen to act like it's always on. Is this possible?

Looks like the USB detection logic is damaged somehow. Unfortunately, I
don't know that much about the H300 hardware, so I can't help you much
more than that...

Linus
Received on 2007-06-30


Page was last modified "Jan 10 2012" The Rockbox Crew
aaa