dev builds
themes manual
device status forums
mailing lists
IRC bugs
dev guide

Rockbox mail archive

Subject: Re: Patching IRiver firmware - strange behavior

Re: Patching IRiver firmware - strange behavior

From: David <>
Date: Wed, 18 Jul 2007 03:00:38 +0200

No, I didn't want any Japanese. And, I agree, I too did think that the JP
stands for Japanese. That's why, in the first turn, I was planning to use
the version ending on an U; as I thought this must be the english version.
Could anyone just confirm if I am right on that part? Should I go for the
1.28U, or the 1.30U, of the firmware file?

Glen: Is what you are saying that I should run the patcher on the H300.hex,
ignore the messages I get, and then run the patcher on the result from the
first run? Sorry, if I am a bit slow, but I just want to do this right...

Thanks again, everybody!

----- Original Message -----
From: "Glenn Ervin" <>
To: "Rockbox" <>
Sent: Wednesday, July 18, 2007 1:37 AM
Subject: Re: Patching IRiver firmware - strange behavior

> ----- Original Message -----
> From: "David" <>
> To: "RB Maling List" <>
> Sent: Tuesday, July 17, 2007 6:09 PM
> Subject: Patching IRiver firmware - strange behavior
> Hi, all!
> I am planning to put RB on my IRiver H320, which I got off from EBay. I
> have
> been browsing the website of RB, for a few days, and thanks to a couple of
> guys in here, I got that far, that I downloaded the patching software.
> On the webpage, the IRiver H320 is listed with different firmwares, the
> 1.28, 1.29, and 1.30. These again, are listed with U, K and J in the end.
> One person here on the list, suggested I should use the 1.29J. Ok, so I
> downloaded that one, That is, the file I got is named
> I unzipped it (by Windows XP's built-in unzip). This resulted in a file
> named H300.HEX; exactly in accordance with the information on the RB
> webpage. So far, everything seemed perfectly well.
> Now, I tried to patch this h300.hex file. The software gives me two
> messages, immediately upon each other:
> Unrecognized firmware
> and
> Firmware patched successfully
> This seems a bit strange, to me. Why, does it tell me Unrecognized
> firmware,
> if it manage to successfully patch the h300.hex?
> I tried to run the patcher on the h300.hex file found in the -
> one
> of the other firmwares listed with h320/340 - but with the same result.
> Could anyone, please, point me in the right direction? Is it safe to use
> the
> h300.hex file, that the patcher has put out, with the above mentioned
> messages? Or, what am I doing wrong. I really don't want to transfer
> anything to my IRiver, till I get this straightened out.
> I tried the version of the patcher without UNIcode, as well, with exactly
> the same result.
> IS there - somewhere out there - somebody who has a working H300.hex file,
> on their H320, that has been patched with RockBox, who could have sent me
> a
> copy?
> Thanks for all your help!
> ** David,
> Did you want the Japanese version?
> I believe that is the JP in the file name.
> Also, it typically does not work the first time, and a second run of the
> patcher will then produce the file you want.
> But again, make sure you are using the language version that you wish.
> Glenn
Received on 2007-07-18

Page was last modified "Jan 10 2012" The Rockbox Crew