Rockbox.org home
release
dev builds
extras
themes manual
wiki
device status forums
mailing lists
IRC bugs
patches
dev guide



Rockbox mail archive

Subject: iriver settings disappearing and usb startup problems

iriver settings disappearing and usb startup problems

From: victor rajewski <askvictor_at_gmail.com>
Date: Wed, 2 Jan 2008 12:47:48 +1100

Two issues, possibly related due to their close proximity in time. First up,
I'm using an iriver h340.

For a few weeks now, the settings in the unit have been disappearing at
least every day (_not_ every power-off, but I haven't been sufficiently
scientific in my observations to determine a pattern). Everything still
worked fine, but my all settings were back to the defaults usually the first
power-on of the day. I was going to upgrade rockbox at some point, but then
the second problem happened:

The unit started thinking it was connected to a usb connection all the time.
This is the same problem described here:
http://www.misticriver.net/forums/h3xx-series-320-340/11314-fixed-h320-always-connected-prob.htmland
happened both in rockbox and the original firmware. I fixed it in the
described fashion.

The third thing to consider is that my battery has been slowly dying for a
month or two.

I'm starting to think these might be related. Many people with the usb
problem have reported shorter battery lives afterward; maybe it's the other
way round - the battery starts dying then causes some hiccup in the power
management unit. As for the settings - I'm guessing are stored in flash
rather than on disk? Could a dying battery be causing this?

Cheers

Victor
**
Received on 2008-01-02


Page was last modified "Jan 10 2012" The Rockbox Crew
aaa