Rockbox.org home
release
dev builds
extras
themes manual
wiki
device status forums
mailing lists
IRC bugs
patches
dev guide



Rockbox mail archive

Subject: Re: creating new .voices for H10 - not working

Re: creating new .voices for H10 - not working

From: Dominik Wenger <domonoky_at_googlemail.com>
Date: Sat, 12 Jan 2008 23:24:07 +0100

I just tested a voice creation with rbutil and jaws and its really not
too good to use with voice only :-)

So to create a voice file, you can use the "Actions" menu (via alt) with
this you can directly jump to the voice generation dialog, and this menu
is well voiced.

In the "Create Voice File" Dialog there is a dropdown menu at the top
which selects the language to generate. (if you open the dropdown with
alt+down jaws reads the entrys).

Under this drop down there is a "Change" Button which lets you directly
jump to the configuration of the TTS engine and the encoder.

In the Configuration dialog there is also a dropdown to select the TTS
engine (use "Sapi5 TTS Engine" for a start). Then there is a button to
configure the selected TTS. (for sapi you dont have to change anything,
maybe the language).
Below is the same for the Encoder. (Set it to rbspeex, and leave the
configuration of it on default).

Use OK Button to close the dialog, and navigate to "Install". Then a
Progress windows shows (Jaws announces it, but doesnt read the
contents). The generation takes a long time, so be patient. At the end
Jaws told me "100 %" then you can close the window with the button on
it, und with luck you have a working voice file on your player :-)

Unfortunatly there is no good way to know if something failed.. (maybe
rbutil should play a sound if it errors ? :-) )

hope i could help..

greets, Domonoky

> Can you, if possible, outline the steps I should take in order to accomplish
> this?
>
...
> Regards,
>
> Stuart.
>
>
>
Received on 2008-01-12


Page was last modified "Jan 10 2012" The Rockbox Crew
aaa