Rockbox.org home
release
dev builds
extras
themes manual
wiki
device status forums
mailing lists
IRC bugs
patches
dev guide



Rockbox mail archive

Subject: Re: I think I bricked my sansa e280.

Re: I think I bricked my sansa e280.

From: Barry Wardell <barry.wardell_at_gmail.com>
Date: Sat, 23 Feb 2008 18:14:34 +0000

On Sat, Feb 23, 2008 at 5:26 PM, Emlyn Addison <noisyblocks_at_gmail.com>
wrote:

> OK, I had some success, but I'm not sure how I keep going.
>
> After I run the e200tool-mac, the player screen lights up with the
> SanDisk startup screen, then it says:
>
> Welcome to recovery mode
>

> Followed by:
>
> USB cable connected
> Enter USB2.0 MSD mode
> LUN0 locked

This is exactly what you want.

The device does not show up anywhere on the desktop (only in disk
> tools, which does not allow any copying TO a drive...except for the
> "restore" function).
>

I think that this is a problem with specific versions of OS X. I don't get
it on the latest version of Leopard, but I do remember having it in the
past. It may also be related to the version of the BL_SD_BoardSupported.rom
file that you use.

Seems like I need to get the device to show up on the desktop to copy
> the .mi4 file, right? (Or must this be done from terminal? I don't
> know how that's done.)
>

Yes, exactly. Unfortunately, I'm not sure how you can manage this other than
trying different combinations of OS X version and BL_SD_BoardSupported.rom.

If (when?) USB supported is added to the Rockbox bootloader, you would be
able to use that instead of the BL_SD_BoardSupported.rom file.
Unfortunately, currently the USB support in Rockbox suffers from the same
symptoms on OS X.

So, your best bet would be to try again on a different (preferably Linux)
system. I think even a linux boot CD would do the job.
Received on 2008-02-23


Page was last modified "Jan 10 2012" The Rockbox Crew
aaa