dev builds
themes manual
device status forums
mailing lists
IRC bugs
dev guide

Rockbox mail archive

Subject: formated hidden partition

formated hidden partition

From: chicken <>
Date: Sun, 08 Feb 2009 13:19:46 -0800

Okay so I am new here (1 hour may be)

the reason is that I kinda formated all my sansa 280 (all plus the
hidden partition)
I was formating my flash drive to install DSL in it and selected my
sansa partition and formated instead, I wasn't aware of that and had
been trying everything althought nothing works, (pressing the record
button) and all that, and I can't mount it (it only appears as
> Bus 004 Device 010: ID 0781:0720 SanDisk Corp. Sansa C200 series in
> recovery mode
I tried using e200tool but as you might know I got nothing to recover
and I don't know where I could get the firmware or the bootloader or do
the partition as I can't mount it or do anything (Any idea? , anyone?)

the screen is all black, and the wheel is always on.

this is what I get when I try usin e200tool
> ./e200tool init
> e200tool v0.2.3-alpha (c) by MrH 2006, 2007
> Searching for device 0781:0720 ... found!
> Initializing USB stub (4780 bytes) ... done!
I also tried mounting it as a mtp drive with mtpfs

sudo mtpfs -o allow_other /media/mount1 ----> ls: cannot access
mount1: Transport endpoint is not connected

umount /media/mount1
umount: /media/mount1 is not in the fstab

I would appreciate any ideas.

Francisco S
List admin:
Received on 2009-02-08

Page was last modified "Jan 10 2012" The Rockbox Crew