Rockbox.org home
release
dev builds
extras
themes manual
wiki
device status forums
mailing lists
IRC bugs
patches
dev guide



Rockbox mail archive

Subject: Re: Noticable Pop Between Tracks (Sansa)

Re: Noticable Pop Between Tracks (Sansa)

From: R.L. Horn <lists_at_eastcheap.org>
Date: Wed, 18 Feb 2009 00:31:05 -0600 (CST)

On Tue, 17 Feb 2009, Michael Sevakis wrote:

> I didn't go as far as you

Actually, I thought I was rather lazy. I did sit down and start to figure
out at precisely what angle my test tone got cut...but then I got bored
and did something else.

> but I did make a new test tone, cut in half on a peak and tried both WAV
> and LAME-encoded versions. The LAME encoded version had a slight pop
> whereas the pure WAV file was seamless.

> I guess the MP3 issue isn't truely solved.

I've come to the conclusion that, without preserving decoder state
information, maybe that's as good as it's going to get. There just
doesn't appear to be sufficient information to construct faithful audio
from an isolated initial mp3 frame.

I'll probably just file a low-priority bug report at leave it at that.

As an aside, in the process of converting my collection to vorbis, I've
already discovered an annoying little glitch in one of my CDs that had
been masked by the "pop", so it's not all bad. :-)
-------------------------------------------------------------------
List admin: http://cool.haxx.se/cgi-bin/mailman/listinfo/rockbox
FAQ: http://www.rockbox.org/twiki/bin/view/Main/GeneralFAQ
Etiquette: http://www.rockbox.org/mail/etiquette.html
Received on 2009-02-18


Page was last modified "Jan 10 2012" The Rockbox Crew
aaa