dev builds
themes manual
device status forums
mailing lists
IRC bugs
dev guide

Rockbox mail archive

Subject: Re: Sansa Clip+ won't turn on

Re: Sansa Clip+ won't turn on

From: pablo f. zavalia via rockbox <>
Date: Mon, 1 Feb 2016 16:39:19 -0300

I though for a minute I got it fixed but not yet:

Then I unsoldered the battery, and plugging it to the laptop it turns on!.
So it isn't broken, at least not dead, I can mount the internal memory and
access the files in it.

I leave it unsoldered about 1 hour, I solder it again and nothing. It doesn't
turn on, plug in the laptop nothing, use the USB wall charger, no change.

With my fingers burned I unsolder again the battery and the damn thing
starts working again.

Now I use the USB wall charger, it start ups and I also let me use the buttons
(when using the laptop it shows a usb icon but doesn't let me press buttons or
use the menu). So now I plug the headphones and I hear a periodic click click
of buttons being pressed, sounds as if a button is pressed all the time. I
test all of them one at a time, it seems to me the power button is stuck
continually pressed.

Not sure why with the battery soldered I can't do anything, but without it it
turns on.. does it make sense? I need to see what I can do, I'm not confident I
have the soldering skills to replace with a new button, maybe I can clean it
somehow.... I'll let you know as soon as I have any news.


Received on 2016-02-01

Page was last modified "Jan 10 2012" The Rockbox Crew