Rockbox.org home
release
dev builds
extras
themes manual
wiki
device status forums
mailing lists
IRC bugs
patches
dev guide



Rockbox mail archive

Subject: RE: kevin: apps alarm_menu.c

RE: kevin: apps alarm_menu.c

From: Anton Oleynikov <len0x_at_mail.ru>
Date: 2005-11-16

> What exactly makes this function called "sync"?

My guess would be it syncs the message on multiple screens, because there is
no
parameter that specifies which screen message should be displayed on.
 
> Also, why oh why didn't you just make your new function use
> the same name? I really don't like seeing every function we have get a
gui_
> prefix for no useful purpose.

IMHO it's a good practice to give functions new names if they are totally
rewritten
because:

 - you don't break old code
 - you can migrate portions of code from old one to the new one and not
everything
   in one go

Anton.
Received on Wed Nov 16 18:33:20 2005


Page was last modified "Jan 10 2012" The Rockbox Crew
aaa