Rockbox.org home
release
dev builds
extras
themes manual
wiki
device status forums
mailing lists
IRC bugs
patches
dev guide



Rockbox mail archive

Subject: Re: Building Manual Fails - SDL Sim fails to Run

Re: Building Manual Fails - SDL Sim fails to Run

From: Christi Alice Scarborough <christi_at_chiark.greenend.org.uk>
Date: 2006-02-12

Mark Bright wrote:
> I have been using the DevKit for some time to make my own build but
> recently ran into problems with the SDL Sim and Manual builds.
>
> To avoid getting embroiled in the middle of the current argument I
> decided to follow the dev's advice and I did the full Cygwin install
>
> It was the 3rd attempt BTW before I managed to get a successful install
> - that installer is CRAP
> Once I am sure that I have a correctly configured full install, I will
> attempt to repeat the process on my laptop, any objections if I screen
> shot it along the way and expand on the current Cygwin install page to
> make it more 'Nube' friendly??
>
> Anyway...
> I successfully made the H120/140 build - Fine nothing I could not do
> before.
>
> I even successfully made the SDL Simulator build, Hurahhh!
> However when I attempted to run the rockboxui.exe I got the error :
> "This application has failed to start because SDL.dll was not found.
> Re-Installing the application may fix this problem" - What have I
> missed, or is there some magic incantation missing from the install
> instructions?

Looks like it's linked dynamically. See if you can find SDL.DLL in your
SDL build directory and copy it into the same directory as the simulator
binary.

> $ make
> make: *** /home/Boffin/rockbox-devel/manual/platform: No such file or
> directory.
> Stop.
> make: *** [tools] Error 2

You did do a 'cvs co manual', right?

Christi
Received on Sun Feb 12 13:24:24 2006


Page was last modified "Jan 10 2012" The Rockbox Crew
aaa