Rockbox.org home
release
dev builds
extras
themes manual
wiki
device status forums
mailing lists
IRC bugs
patches
dev guide



Rockbox mail archive

Subject: Re: Problem compiling with Cygwin

Re: Problem compiling with Cygwin

From: Andrew Hart <ahart_at_dim.uchile.cl>
Date: Fri, 29 Sep 2006 08:43:20 -0400

Jonas,

Hi. The stock standard gcc in my cygwin distribution (which I-ve never
bothered upgrading) is 3.3.3. But the m68k-elf-gcc which i use for
cross-compiling Rockbox for my H300 is version 3.4.4. As you can tell,
I don't have a dev. env. set up for compiling Rockbox on all platforms
as yet.

Do I need a later version than 3.4.4?

Many thanks,
Andrew.

Jonas H wrote:
> Andrew Hart wrote:
>> Hi folks,
>>
>> I just updated my cvs to the latest. It's been a week or so since I
>> last did this. However, now I cannot compile an Iriver H300 build under
>> Cygwin any more. GCC gives me an error message that is totally beyond
>> me. I've pasted the output from make below.
>>
>> The problem is in the libfaad plug-in.
>> Anyone got any idea what recent change might have broken H300 Cygwin
>> builds?
>
> You probably need to upgrade GCC. What does gcc -v tell you?
>
Received on 2006-09-29


Page was last modified "Jan 10 2012" The Rockbox Crew
aaa